Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Below are typical user errors of configuring Layer 3 Hardware Offloading.

VLAN interface on a switch port or bond

Code Block
languageros
/interface /vlan 
add name=vlan10 vlan-id=10 interface=sfp-sfpplus1
add name=vlan20 vlan-id=20 interface=bond1

VLAN interface must be set on the bridge due to Layer 2 Dependency. Otherwise, L3HW will not work. The correct configuration is:

Code Block
languageros
/interface /bridge /port 
add bridge=bridge1 interface=sfp-sfpplus1 pvid=10
/interface bridge vlan frame-types=admit-only-vlan-tagged
add bridge=bridge1 interface=bond1 frame-types=admit-only-vlan-tagged
 
/interface/bridge/vlan
add bridge=bridge1 tagged=bridge1,sfp-sfpplus1 vlan-ids=10
add bridge=bridge1 tagged=bridge1,bond1 vlan-ids=20
 
/interface/vlan
add name=vlan10 vlan-id=10 interface=bridge1
add name=vlan10vlan20 vlan-id=1020 interface=bridge1

Not adding the bridge interface to /in/br/vlan

...