The ZeroTier network hypervisor is a self-contained network virtualization engine that implements an Ethernet virtualization layer similar to VXLAN built atop a cryptographically secure global peer to peer network. It provides advanced network virtualization and management capabilities on par with an enterprise SDN switch, but across both local and wide area networks and connecting almost any kind of app or device.

MikroTik has added ZeroTier to RouterOS v7.1rc2 as a separate package for ARM architecture. 

Quick setup

  1. Register on my.zerotier.com and create your network, obtain the Network ID XXXXXXXXX
  2. Install zerotier NPK package in RouterOS
  3. Enable the default (official) zerotier instance: 
    [sergejs@Home] /zerotier>enable zt1
  4. Add a new network, specifying the network ID you created in the zerotier cloud console: 
    [sergejs@Home] /zerotier/interface> add network=YYYYYYYYY instance=zt1
  5. Now you might need to allow connections from the zerotier interface to your router, and optionally, to your other LAN interfaces: 
    [sergejs@Home] /ip firewall filter> add action=accept chain=forward in-interface=zerotier1 place-before=0
    [sergejs@Home] /ip firewall filter> add action=accept chain=input in-interface=zerotier1 place-before=0
  6. Install a zerotier client in your smartphone or computer, follow the zerotier manual on how to connect to the same network from there. 


Tip: You should specify routes to specific internal subnets in the zerotier cloud console, to make sure you can access those networks when connecting from other devices. 

Configuration

General configuration in the /zerotier menu.

Networks are configured in the /zerotier/interface menu. 

  • No labels