You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 3 Next »

Introduction

MLAG (Multi-chassis Link Aggregation Group) implementation in RouterOS allows configuring LACP bonds on two separate devices, while the client device believes to be connected on the same machine. This provides a physical redundancy in case of switch failure. All CRS3xx series devices can be configured with MLAG.

Both peers establish the MLAG interface and update the bridge host table using ICCP (Inter Chassis Control Protocol). RouterOS ICCP does not require an IP configuration, but it should be isolated from the network traffic using a dedicated untagged VLAN. This untagged VLAN can be configured with enabled vlan-filtering and pvid

Quick setup

in this example, CRS317 and CRS309 devices are used as MLAG peers and any device with two SFP+ interfaces can be used as an LACP client, see a network scheme below.

Below are configuration commands to configure a RouterOS LACP bonding on the Client device: 

/interface bonding
add mode=802.3ad name=bond1 slaves=sfp-sfpplus1,sfp-sfpplus2

 First, configure bonding interface for MLAG on Peer1 and Peer2 devices, use a matching mlag-id setting on both peer devices:

/interface bonding
add mlag-id=10 mode=802.3ad name=client-bond slaves=sfp-sfpplus2

Next, configure bridge with enabled vlan-filtering, and add needed interfaces as bridge ports. A dedicated untagged VLAN should be applied for the inter-chassis communication on peer ports, thus a different pvid setting is used. Below are configuration commands for Peer1 and Peer2 devices:

/interface bridge
add name=bridge1 vlan-filtering=yes
/interface bridge port
add bridge=bridge1 interface=sfp-sfpplus1 pvid=99
add bridge=bridge1 interface=client-bond

All VLANs that are allowed on MLAG ports should also be allowed on peer ports on both devices. In the previous step, peer ports were placed on a dedicated untagged VLAN, so peer ports now are added as tagged VLAN 1 member ports (the default pvid for MLAG bridge ports). Other VLANs can be added if needed. Below are configuration commands for both peer devices:

Error rendering macro 'code': Invalid value specified for parameter '[Ljava.lang.Object;@6179ee11'
/interface bridge vlan
add bridge=bridge1 tagged=sfp-sfpplus1 vlan-ids=1

Last, specify bridge and peer-port to enable MLAG. Below are configuration commands for both peer devices:

/interface bridge mlag
set bridge=bridge1 peer-port=sfp-sfpplus1


Configuration options


Monitoring and troubleshooting

Configuration examples

  • No labels