You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 14 Next »



/routing/id

Global Router ID election configuration. ID can be configured explicitly or set to be elected from one of the Routers IP addresses.

For each VRF table RouterOS adds dynamic ID instance, that elects the ID from one of the IP addresses belonging to a particular VRF:

[admin@rack1_b33_CCR1036] /routing/id> print 
Flags: D - DYNAMIC, I - INACTIVE
Columns: NAME, DYNAMIC-ID, SELECT-DYNAMIC-ID, SELECT-FROM-VRF
#   NAME   DYNAMIC-ID      SELECT-D   SELE
0 D main   111.111.111.2   only-vrf   main

Configuration Options

PropertyDescription
comment (string)
disabled (yes | no)ID reference is not used.
id(IP)Parameter to explicitly set the Router ID. If ID is not explicitly specified, then it can be elected from one of the configured IP addresses on the router. See parameters select-dynamic-id and select-from-vrf.
name (string)Reference name
select-dynamic-id(any | lowest | only-active | only-loopback | only-static | only-vrf)States what IP addresses to use for the ID election:
  • any - any address found on the router can be elected as the Router ID.
  • lowest - pick the lowest IP address.
  • only-active - pick an ID only from active IP addresses.
  • only-loopback - pick an ID only from loopback addresses.
  • only-vrf - pick an ID only from selected VRF. Works with select-from-vrf property.
select-from-vrf (name)VRF from which to select IP addresses for the ID election.


Read-only Properties

PropertyDescription
dynamic (yes | no)
dynamic-id (IP)Currently selected ID.
inactive (yes | no)If there was a problem to get a valid ID, then item can become inactive.

/routing/table

If custom routing table is required, it should be defined in this menu prior to use it anywhere in the configuration.

By default RouterOS defines 'main' routing table which adds routes in the FIB.

[admin@rack1_b33_CCR1036] /routing/table> print 
Flags: D - dynamic; X - disabled, I - invalid; U - used 
0 D name="main" fib 

Configuration Example

Let's consider a basic example where we want to resolve 8.8.8.8 only in the routing table named 'myTable' to the gateway 172.16.1.1:

/routing table add name=myTable fib
/routing rule add dst-address=8.8.8.8 action=lookup-only-in-table table=myTable
/ip route add dst-address=8.8.8.8 gateway=172.16.1.1@main routing-table=myTable

Configuration Options

PropertyDescription
comment (string)
disabled (yes | no)ID reference is not used.
fib()Flag indicating whether routing table should add routes in the FIB.
name (string)Name of the routing table

Read-only Properties

PropertyDescription
dynamic (yes | no)
invalid (yes | no)
used (yes | no)

Read Next

  • No labels