Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.


Panel
titleIn This Section:

Page Tree

Table of Contents

/routing/id

Global Router ID election configuration. ID can be configured explicitly or set to be elected from one of the Routers IP addresses.

For each VRF table RouterOS adds dynamic ID instance, that elects the ID from one of the IP addresses belonging to a particular VRF:

Code Block
languagetext
themeFadeToGrey
[admin@rack1_b33_CCR1036] /routing/id> print 
Flags: D - DYNAMIC, I - INACTIVE
Columns: NAME, DYNAMIC-ID, SELECT-DYNAMIC-ID, SELECT-FROM-VRF
#   NAME   DYNAMIC-ID      SELECT-D   SELE
0 D main   111.111.111.2   only-vrf   main

Configuration Options

...

  • any - any address found on the router can be elected as the Router ID.
  • lowest - pick the lowest IP address.
  • only-active - pick an ID only from active IP addresses.
  • only-loopback - pick an ID only from loopback addresses.
  • only-vrf - pick an ID only from selected VRF. Works with select-from-vrf property.

...

Read-only Properties

...

/routing/table

If custom routing table is required, it should be defined in this menu prior to use it anywhere in the configuration.

By default RouterOS defines 'main' routing table which adds routes in the FIB.

Code Block
languagetext
themeFadeToGrey
[admin@rack1_b33_CCR1036] /routing/table> print 
Flags: D - dynamic; X - disabled, I - invalid; U - used 
0 D name="main" fib 

Configuration Example

Let's consider a basic example where we want to resolve 8.8.8.8 only in the routing table named 'myTable' to the gateway 172.16.1.1:

Code Block
languageros
/routing table add name=myTable fib
/routing rule add dst-address=8.8.8.8 action=lookup-only-in-table table=myTable
/ip route add dst-address=8.8.8.8 gateway=172.16.1.1@main routing-table=myTable

Configuration Options

...

Read-only Properties

...

/routing/rule

Routing rule configuration.

Configuration Options

...

An action to take on the matching packet:

  • drop - silently drop the packet.
  • lookup - perform lookup in routing tables.
  • lookup-only-in-table - perform lookup only in specified routing table (see table parameter).
  • unreachable - generate ICMP unreachable message and send it back to the source.

...

Read Next

...

rootRouting