Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Support for Direct-IP mode type cards only. MBIM support is available in RouterOS v7 releases and the MBIM driver is loaded automatically. If the modem is not recognized in RouterOS v6 - Please test it in v7 releases before asking for support in RouterOS v6.

To enable access via a PPP interface instead of a LTE Interface, change direct IP mode with /port firmware set ignore-directip-modem=yes command and a reboot. Note that using PPP emulation mode you may not get the same throughput speeds as using the LTE interface emulation type. 

Note

For RouterOS v7 ignore-direct-modem parameter was renamed to "mode" and moved to to /interface lte settings menu.

LTE Client

Code Block
languageros
Sub-menu: /interface lte

...

PropertyDescription
allow-roaming (yes | no; Default: no)Enable data roaming for connecting to other countries' data-providers. Not all LTE modems support this feature. Some modems, that do not fully support this feature, will connect to the network but will not establish an IP data connection with allow-roaming set to no.
apn-profiles (string; Default: default)Which APN profile to use for this interface
band (integer list; Default: "")LTE Frequency band used in communication LTE Bands and bandwidths
nr-band (integer list; Default: "")5G NR Frequency band used in communication 5G NR Bands and bandwidths
comment (string; Default: "")Descriptive name of an item
disabled (yes | no; Default: yes)Whether the interface is disabled or not. By default it is disabled.
modem-init (string; Default: "")Modem init string (AT command that will be executed at modem startup)
mtu (integer; Default: 1500)Maximum Transmission Unit. Max packet size that the LTE interface will be able to send without packet fragmentation.
name (string; Default: "")Descriptive name of the interface.
network-mode (3g | gsm | lte | 5g)Select/force mode for LTE interface to operate with
operator (integer; Default: "")used to lock the device to a specific operator full PLMN number is used for the lock consisting from of MCC+MNC. PLMN codes
pin (integer; Default: "")SIM Card's PIN code.

APN profiles

All network-related settings are moved under profiles, starting from RouterOS 6.41

Code Block
languageros
Sub-menu: /interface lte apn

...

PropertyDescription
add-default-route (yes | no)Whether to add a default route to forward all traffic over the LTE interface.
apn (string)Service Provider's Access Point Name
authentication (pap | chap | none; Default: none)Allowed protocol to use for authentication
default-route-distance (integer; Default: 2)Sets distance value applied to auto-created default route, if add-default-route is also selected. LTE route by default is with distance 2 to prefer wired routes over LTE
ip-type (ipv4 | ipv4-ipv6 | ipv6; Default: )Requested PDN type
ipv6-interface (; Default: )Interface on which to advertise IPv6 prefix
name (string; Default: )APN profile name
number (integer; Default: )APN profile number
passthrough-interface (; Default: )Interface to passthrough IP configuration (activates passthrough)
passthrough-mac (MAC; Default: auto)If set to auto, then will learn MAC from the first packet
passthrough-subnet-selection (auto / p2p; Default: auto)"auto" selects the smallest possible subnet to be used for the passthrough interface. "p2p" sets the passthrough interface subnet as /32 and picks gateway address from 10.177.0.0/16 range. The gateway address stays the same until the apn configuration is changed.
password (string; Default: )Password used if any of the authentication protocols are active
use-network-apn (yes | no; Default: yes)Parameter is available starting from RouterOS v7 and used only for MBIM modems. If set to yes, uses network provided APN.
use-peer-dns (yes | no; Default: yes)If set to yes, uses DNS recieved received from LTE interface
user (integer)Username used if any of the authentication protocols are active

...

PropertyDescription
mode (auto | mbim | serial / user; Default: auto)

Operation mode setting.

  • auto - automatically select the operation mode.
  • serial - provide only serial ports
  • mbim - switch modem into MBIM mode if possible
  • user - OS will not attempt to automatically switch the modem mode. (Available from RouterOS 7.16)
firmware-path (string)Firmware path in host OS. Modem gobi firmware
external-antenna (auto | both | div | main | none; Default: auto)This setting is only available for "Chateau" routers, except for Chateau 5G versions.
  • auto - measures the signal levels on both internal and external antennas and selects the antennas with the best signal(RSRP).
  • both - both antennas are set to external
  • div - diversity antenna set to external
  • main - main antenna set to external
  • none - no external antenna selected(using internal antennas) 
external-antenna-selected ()This setting is only available for "Chateau" routers, except for Chateau 5G versions. Shows the currently selected antenna if "external-antenna" is set to "auto"
sim-slot ()This setting is available for routers that have switchable SIM slots (LtAP, SXT). Selection options differ between products.

...

It is possible to scan LTE interfaces with /interface lte scan command. Example:

Code Block
languageros
[admin@MikroTik] > /interface lte scan duration=60 number=0 
Columns: OPERATOR, MCC-MNC, RSSI, RSRP, RSRQ
OPERATOR  MCC-MNC  RSSI    RSRP    RSRQ
LMT         24701  -36dBm  -63dBm  -7dB

...

User Info command

It is possible to send a special "info" command to LTE interface with with /interface lte info command. In RouterOS v7 this command is moved to /interface lte monitor menu.

Properties (Up to 6.40)

PropertyDescription
user-command (string; Default: "")send a command to the LTE card to extract useful information, e.g. with AT commands
user-command-only (yes | no; Default: )

...

It is possible to send user defined "at-chat" command to the LTE interface with with /interface lte at-chat command.

Code Block
languageros
[admin@MikroTik] > /interface lte at-chat lte1 input="AT"
  output: OK

...

Code Block
languageros
[admin@MikroTik] > :global "lte_command" [/interface lte at-chat lte1 input="AT+CEREG?" as-value ] 
[admin@MikroTik] > :put $"lte_command" 
output=+CEREG: 0,1
OK

Quick setup example

Start with network settings -

...

Start with network settings - Add new connection parameters under LTE apn profile (provided by network provider):

Code Block
languageros
/interface lte apn add name=profile1 apn=phoneprovider.net authentication=chap password=web user=web

Select the newly created profile for an LTE connection:

Code Block
languageros
/interface lte set [find] apn-profiles=profile1 

LTE interface should appear with the running (R) flag:

Code Block
languageros
[admin@MikroTik] > /interface lte print
Flags: X - disabled, R - running 
0 R name="lte1" mtu=1500 mac-address=AA:AA:AA:AA:AA:AA 

...

Code Block
languageros
/ip firewall nat add action=masquerade chain=srcnat out-interface=lte1

After the interface is added, you can use the "info" command to see what parameters the client acquired (parameters returned depends on the LTE hardware device):

No Format
languageros
nopaneltrue
[admin@MikroTik] > interface/interface lte info lte1 once 
status: call in progress
pin-status: no password required
functionality: full
manufacturer: Huawei Technologies Co., Ltd.
model: ME909u-521
revision: 12.631.07.01.00
current-operator: vodafone ES
current-cellid: 44436007
access-technology: Evolved 3G (LTE)
signal-strengh: -79 dBm
frame-error-rate: n/a
earfcn: n/a
imei: 860461024123456
imsi: 234012555034981
uicc: n/a
rssi: -79dBm
rsrp: -109dBm
rsrq: -13dB
sinr: -1dB

Passthrough Example

/monitor lte1                                                                                                            
            status: connected
             model: EG18-EA
          revision: EG18EAPAR01A12M4G
  current-operator: LMT
    current-cellid: 3103242
            enb-id: 12122
         sector-id: 10
        phy-cellid: 480
        data-class: LTE
    session-uptime: 15m54s
              imei: 86981604098XXXX
              imsi: 24701060267XXXX
              uicc: 8937101122102057XXXX
      primary-band: B3@20Mhz earfcn: 1300 phy-cellid: 480
     dl-modulation: qpsk
               cqi: 7
                ri: 2
               mcs: 1
              rssi: -68dBm
              rsrp: -97dBm
              rsrq: -9dB
              sinr: 6dB

Passthrough Example

Some LTE interfaces support the LTE Passthrough feature where the Starting from RouterOS v6.41 some LTE interfaces support LTE Passthrough feature where the IP configuration is applied directly to the client device. In this case, modem firmware is responsible for the IP configuration, and the router is used only to configure modem settings - APN, Network Technologies, and IP-Type. In this configuration, the router will not get IP configuration from the modem. The LTE Passthrough modem can pass both IPv4 and IPv6 addresses if that is supported by the modem. Some modems support multiple APN APNs where you can pass the traffic from each APN to a specific router interface.

Passthrough will only work for one host. Router The router will automatically detect the MAC address of the first received packet and use it for the Passthrough. If there are multiple hosts on the network it is possible to lock the Passthrough to a specific MAC. On the host on the network where the Passthrough is providing the IP a DHCP-Client should be enabled on that interface totoo. Note, that it will not be possible to connect to the LTE router via a public lte ip IP address or from the host which is used by the passthrough. It is suggested to create an additional connection from the LTE router to the host for configuration purposes. For example vlan interface between the LTE router and host.

To enable the Passthrough a new entry is required or the default entry should be changed in the '/interface lte apn' menu

Note
Passthrough is not supported by all chipsets.

...

To configure multiple APNs with the same APN for different interfaces:

Code Block
languageros
[admin@MikroTik] > /interface lte apn add name=interface1 apn=apn1
[admin@MikroTik] > /interface lte apn add name=interface2 apn=apn1 passthrough-interface=ether1
[admin@MikroTik] > /interface lte apnset addlte1 nameapn-profiles=interface1 apn=apn1
[admin@MikroTik] > 
[admin@MikroTik] > /interface lte set lte2 apn-profiles=interface2

Dual SIM

Boards with switchable SIM slots

RouterBoardModem slotSIM slotsSwitchable
LtAP

lower2 | 3Y
upper1N
LtAP mini
up | downY
SXT R
a |  bY

SIM slots switching commands

  • RouterOS v7
Code Block
languageros
/interface lte apnsettings add name=interface2 apn=apn1 passthrough-interface=ether1
[admin@MikroTik] > /interface lte set lte1 apn-profiles=interface1
[admin@MikroTik] > /interface lte set lte2 apn-profiles=interface2

Dual SIM

Boards with switchable SIM slots

...

set sim-slot=down
  • RouterOS v6 after 6.45.1
Code Block
languageros
/system routerboard modem set sim-slot=down
  • RouterOS v6 pre 6.45.1:
Code Block
languageros
/system routerboard sim set sim-slot=down

For more reference please see the board block diagram,  Quick Guide, and User manual.

Usage Example

Follow this link - Dual SIM Application, to see examples of how to change SIM slot based on roaming status and in case the interface status is down, with the help of RouterOS scripts and scheduler.

Tips and Tricks

This paragraph contains information for additional features and usage cases.

Find device location using Cell information

On devices using the R11e-LTE International version card (wAP LTE kit) some extra information is provided under info command.

No Format
languageros
nopaneltrue
   current-operator: 24701
                lac: 40
     current-cellid: 2514442


PropertyDescription
current-operator (integer; Default: )Contains MCC and MNC. For example: current-operator: 24701 breaks to: MCC=247 MNC=01
lac (integer; Default: )location area code (LAC)
current-cellid (integer; Default: )Station identification number

Values can be used to find location in databases: Cell Id Finder

Using Cell lock

It is possible to lock R11e-LTE, R11e-LTE6 and R11e-4G modems and equipped devices to the exact LTE tower. LTE info command provides currently used cellular tower information:

...

SIM slots switching commands

  • RouterOS v7
Code Block
languageros
/interface lte settings set sim-slot=down
  • RouterOS v6 after 6.45.1
Code Block
languageros
/system routerboard modem set sim-slot=down
  • RouterOS v6 pre 6.45.1:
Code Block
languageros
/system routerboard sim set sim-slot=down

For more reference please see board block diagram,  Quick Guide and User manual.

Usage Example

Follow this link - Dual SIM Application, to see examples of how to change SIM slot based on roaming status and in case the interface status is down with help of RouterOS scripts and scheduler.

Tips and Tricks

This paragraph contains information for additional features and usage cases.

Find device location using Cell information

On devices using R11e-LTE International version card (wAP LTE kit) some extra information is provided under info command (from 6.41rc61)

No Format
languageros
nopaneltrue
   current-operator: 24701
      phy-cellid: 384
           lac: 40
 earfcn: 1300 (band  current-cellid: 25144423, bandwidth 20Mhz)


PropertyDescription
phy-cellid
PropertyDescription
current-operator (integer; Default: )Contains MCC and MNC. For example: current-operator: 24701 breaks to: MCC=247 MNC=01
lac (integer; Default: )location area code (LAC)Physical Cell Identification (PCI) of currently used cell tower.
earfcn current-cellid (integer; Default: )Station identification number

Values can be used to find location in databases: Cell Id Finder

Using Cell lock

Absolute Radio Frequency Channel Number

Exact tower location as well as available bands and other information can be acquired from mobile carrier or by using online services:

CellMapper

By using those acquired variables it's possible to send the AT command to modem for locking to tower in the current format:

for R11e-LTE and R11e-LTE6It is possible to lock R11e-LTE, R11e-LTE6 and R11e-4G modems and equipped devices to exact LTE tower. LTE info command provides currently used cellular tower information:

No Format
languageros
nopaneltrue
         phy-cellid: 384
             earfcn: 1300 (band 3, bandwidth 20Mhz)

...

AT*Cell=<mode>,<NetworkMode>,<band>,<EARFCN>,<PCI>

where

<mode> :
0 – Cell/Frequency disabled
1 – Frequency lock enabled
2 – Cell lock enabled

<NetworkMode>
0 – GSM
1 – UMTS_TD
2 – UMTS_WB
3 – LTE

<band>
Not in use, leave this blank

<EARFCN>
earfcn from lte info

<PCI>
phy-cellid from lte info

To lock modem at previously used tower at-chat can be used:

Code Block
languageros
/interface lte at-chat lte1 input="AT*Cell=2,3,,1300,384"

For R11e-LTE all set on locks are lost after reboot or modem reset. Cell data can be also gathered from "cell-monitor".

For R11e-LTE6 cell lock works only for the primary band, this can be useful if you have multiple channels on the same band and you want to lock it to a specific earfcn. Note, that cell lock is not band-specific and for ca-band it can also use other frequency bands, unless you use band lock.

Use cell lock to set the primary band to the 1300 earfcn and use the second channel for the ca-band:

Code Block
languageros
/interface lte at-chat lte1 input="AT*Cell=2,3,,1300,138"

Now it uses the earfcn: 1300 for the primary channel:

Exact tower location as well as available bands and other information can be acquired from mobile carrier or by using online services:

CellMapper

By using those acquired variables it's possible to send AT command to modem for locking to tower in current format:

for R11e-LTE and R11e-LTE6

No Format
languageros
nopaneltrue
AT*Cell=<mode>,<NetworkMode>,<band>,<EARFCN>,<PCI>

where

<mode> :
0 – Cell/Frequency disabled
1 – Frequency lock enabled
2 – Cell lock enabled

<NetworkMode>
0 – GSM
1 – UMTS_TD
2 – UMTS_WB
3 – LTE

<band>
Not in use, leave this blank

<EARFCN>
earfcn from lte info

<PCI>
phy-cellid from lte info
         primary-band: B3@20Mhz earfcn: 1300 phy-cellid: 138
              ca-band: B3@5Mhz earfcn: 1417 phy-cellid: 138

You can also set it the other way aroundTo lock modem at previously used tower at-chat can be used:

Code Block
languageros
/interface lte at-chat lte1 input="AT*Cell=2,3,,13001417,384"

For R11e-LTE all set on locks are lost after reboot or modem reset. Cell data can be also gathered from "cell-monitor".

For R11e-LTE6 cell lock works only for the primary band, this can be useful if you have multiple channels on the same band and you want to lock it to a specific earfcn. Note, that cell lock is not band-specific and for ca-band it can also use other frequency bands, unless you use band lock.

138"

Now it uses the earfcn: 1417 for the primary channel:

No Format
languageros
nopaneltrue
         primary-band: B3@5Mhz earfcn: 1417 phy-cellid: 138
              ca-band: B3@20Mhz earfcn: 1300 phy-cellid: 138

For R11e-LTE6 modem cell lock information will not be lost after reboot or modem reset. To remove cell lock use at-chat commandUse cell lock to set the primary band to the 1300 earfcn and use the second channel for the ca-band:

Code Block
languageros
/interface lte at-chat lte1 input="AT*Cell=2,3,,1300,1380"

Now it uses the earfcn: 1300 for the primary channel:for R11e-4G

No Format
languageros
nopaneltrue
AT%CLCMD=<mode>,<mode2>,<EARFCN>,<PCI>,<PLMN>
AT%CLCMD=1,1,3250,244,\"24705\"

where

<mode> :
0  Cell/Frequency disabled
1  Cell lock  primary-band: B3@20Mhz earfcn: 1300 phy-cellid: 138
              ca-band: B3@5Mhz earfcn: 1417 phy-cellid: 138

You can also set it the other way around:

Code Block
languageros
/interface lte at-chat lte1 input="AT*Cell=2,3,,1417,138"

Now it uses the earfcn: 1417 for the primary channel:

No Format
languageros
nopaneltrue
         primary-band: B3@5Mhz earfcn: 1417 phy-cellid: 138
              ca-band: B3@20Mhz earfcn: 1300 phy-cellid: 138
enabled

<mode2> :
0 - Save lock for first scan
1 - Always use lock 
(after each reset modem will clear out previous settings no matter what is used here)

<EARFCN>
earfcn from lte info

<PCI>
phy-cellid from lte info

<PLMN>
Mobile operator code

All PLMN codes available here this variable can be also left blank

To lock the modem to the cell - modem needs to be in non operating state, the easiest way for R11e-4G modem is to add CellLock line to "modem-init" string:

Code Block
languageros
/interface lte set lte1 modem-init="AT%CLCMD=1,1,3250,244,\"24705\""

Multiple cells can also be added by providing a list instead of one tower information in the following format:

No Format
languageros
nopaneltrue
AT%CLCMD=<mode>,<mode2>,<EARFCN_1>,<PCI_1>,<PLMN_1>,<EARFCN_2>,<PCI_2>,<PLMN_2>

For example to lock to two different PCIs within the same band and operatorFor R11e-LTE6 modem cell lock information will not be lost after reboot or modem reset. To remove cell lock use at-chat command:

Code Block
languageros
/interface lte at-chatset lte1 inputmodem-init="AT*Cell=0"

for R11e-4G

...

languageros
nopaneltrue

...

AT%CLCMD=1,1,6300,384,\"24701\",6300,385,\"24701\""

for Chateau LTE12, Chateau 5G, LHG LTE18 and ATL LTE18

AT+QNWLOCK="common/4g",<num of cells>,[[<freq>,<pci>],...]
AT+QNWLOCK=\"common/4g\",1,6300,384

where

<num of cells>
number of cells to cell lock

<freq>
earfcn from lte info

...

<pci>
phy-cellid from lte info

...

Single-cell lock example

All PLMN codes available here this variable can be also left blank

To lock modem to the cell - modem needs to be in non operating state, easiest way for R11e-4G modem is to add CellLock line to "modem-init" string:

Code Block
languageros
/interface lte setat-chat lte1 modem-initinput="AT%CLCMD=1AT+QNWLOCK=\"common/4g\",1,3250,244,\"247053050,448"

Query current configuration:

Code Block
languageros
/interface lte at-chat lte1 input="AT+QNWLOCK=\"common/4g\""

Multiple cells can also be added by providing list instead of one tower information in following format:to the cell lock. For example to lock to two different cells:

Code Blocknoformat
languageros
nopaneltrue
AT%CLCMD=<mode>,<mode2>,<EARFCN_1>,<PCI_1>,<PLMN_1>,<EARFCN_2>,<PCI_2>,<PLMN_2>
/interface lte at-chat lte1 input="AT+QNWLOCK=\"common/4g\",2,3050,448,1574,474"


To remove the cell lock use this at-chat commandFor example to lock to two different PCIs within same band and operator:

Code Block
languageros
/interface lte set at-chat lte1 modem-initinput="AT%CLCMD=1,1,6300,384,\"24701\",6300,385,\"24701\""

for Chateau LTE12, Chateau 5G, LHG LTE18 and ATL LTE18

AT+QNWLOCK="common/4g",<num of cells>,[[<freq>,<pci>],...]
AT+QNWLOCK=\"common/4g\",1,6300,384

where

<num of cells>
number of cells to cell lock

<freq>
earfcn from lte info

<pci>
phy-cellid from lte info

Single cell lock example:

Code Block
languageros
/interface lte at-chat lte1 input="AT+QNWLOCK=\"common/4g\",1,3050,448"

Query current configuration:

Code Block
languageros
/interface lte at-chat lte1 input="AT+QNWLOCK=\"common/4g\""

Multiple cells can also be added to the cell lock. For example to lock to two different cells:

Code Block
languageros
/interface lte at-chat lte1 input="AT+QNWLOCK=\"common/4g\",2,3050,448,1574,474"
at+qnwlock=\"common/4g\",0"
Note
1. Cell lock information will not be saved after a reboot or modem reset. 2. AT+QNWLOCK command can lock the cell and frequency. Therefore, the module can be given priority to register to the locked cell, however, according to the 3gpp protocol, the module will be redirected or handover to a cell with better signal instructions, even if it is not within the lock of the command. This phenomenon is normal.

for Chateau LTE6

AT+GTCELLLOCK=<mode>[,<rat>,<type>,<earfcn>[,<PCI>]]

where
< mode >: integer type; 0 Disable this function 1 Enable this function 2 Add new cell to be locked
<rat>: integer type; 0 LTE 1 WCDMA
<type>: integer type; 0 Lock PCI 1 Lock frequency
<earfcn>: integer type; the range is 0-65535.
<PCI>: integer type; If second parameter value is 0, the range is 0-503 for LTE If second parameter value is 1, the rang is 0-512 for WCDMA

ExampleTo remove the cell lock use this at-chat command:

Code Block
languageros
/interface lte at-chat lte1 input="at+qnwlock=\"common/4g\",0"
Note
1. Cell lock information will not be saved after a reboot or modem reset. 2. AT+QNWLOCK command can lock the cell and frequency. Therefore, the module can be given priority to register to the locked cell, however, according to the 3gpp protocol, the module will be redirected or handover to a cell with better signal instructions, even if it is not within the lock of the command. This phenomenon is normal.
AT+GTCELLLOCK=1,0,0,6175,176" 

Cell Monitor

Cell monitor allows to scan available nearby mobile network cells:

...

It is possible to use AT commands to lock to the desired band manually.

To check all supported bands run the at-chat command:

Code Block
languageros
[admin@MikroTik] /interface lte at-chat lte1 input="AT^SYSCFGEX=\?"

output: ^SYSCFGEX: ("00","03","02","01","99"),((2000004e80380,"GSM850/GSM900/GSM1800/GSM1900/WCDMA BCI/WCDMA BCII/WCDMA BCV/WCDMA BCVIII"),
(3fffffff,"All Bands")),(0-2),(0-4),((800d7,"LTE BC1/LTE BC2/LTE 
BC3/LTE BC5/LTE BC7/LTE BC8/LTE BC20"),(7fffffffffffffff,"All Bands")) 
OK


...

All band HEX values and AT commands can be found in Huawei AT Command Interface Specification guide

Check if the band is locked:

Code Block
languageros
[admin@MikroTik] /interface lte at-chat lte1 input="AT^SYSCFGEX\?"

output: ^SYSCFGEX: "03",3FFFFFFF,0,2,40
OK

...

In case your modem is not being recognized after a soft reboot, then you might need to add a delay before the USB port is being initialized. This can be done using the following command:

...

Modem firmware upgrade

Note
Before attempting an LTE modem firmware upgrade - upgrade RouterOS version to the latest releases How To Upgrade RouterOS


Starting from RouterOS version 6.44beta20 it It is possible to upgrade modems firmware. The firmware upgrade is also possible for the Chateau series products starting from the 7.1beta1 version.

Firmware update is available only as FOTA Firmware Over The Air - firmware upgrade can only be done through a working mobile connection for:

...

  • )EG12-EA (Chateau LTE12)
  • )RG502Q-EA (Chateau 5G)
  • )EG18-EA (LHG LTE18)

Firmware updates usually includes small include stability improvements in stability or small bug fixes that can't be included into in RouterOS.

Check the currently used firmware version by running:

...

Code Block
languageros
[admin@MikroTik] > /interface lte firmware-upgrade lte1 upgrade=yes
  status: downloading via LTE connection (>2min)


Info
Whole The whole upgrade process may take up to 10 minutes, depending on mobile connection speed.

After a successful upgrade issue USB power-reset, reboot device or run AT+reset command, to update the modem version readout under info command:

...

Some operators (TMobile, YOTA etc.) allows allow unlimited data only for the device the SIM card is used on, all other data coming from mobile hotspots or tethering is highly limited by volume or by throughput speed. Some sources have found out that this limitation is done by monitoring TTL (Time To Live) values from packets to determinate determine if limitations need to be applied (TTL is decreased by 1 for each "hop" made). RouterOS allows changing the TTL parameter for packets going from the router to allow hiding sub networks. Keep in mind that this may conflict with fair use policy.

...

Unlocking SIM card after multiple wrong PIN code attempts

After locking the SIM card, unlock can be done through "at-chat"

...