Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

PropertyDescription
address (IP/IPv6 address; Default: 0.0.0.0)

SMTP server's IP address.

from (string; Default: <>)Name or email address that will be shown as a receiver.
password (string; Default: "")Password used for authenticating to an SMTP server.
port (integer[0..65535]; Default: 25)SMTP server's port.
tls (no|yes|starttls; Default: no)Whether to use TLS encryption:
  • yes   - sends STARTTLS and continue without TLS if a server responds that drops the session if TLS is not available ;on the server
  • no - do not send STARTTLS;
  • starttls - sends STARTTLS and drops the session if continue without TLS if a server responds that TLS is not available on the server.
user (string; Default: "")The username used for authenticating to an SMTP server.

vrf (VRF name; default value: main)

Set VRF on which service is creating outgoing connections.


Note
Note: All server's configurations (if specified) can be overridden by send command. If tls='''starttls''', port 465 will be used

...

Sending Email


Code Block
languageros
/tool e-mail send

...

PropertyDescription
body (string; Default: )The actual body of the email message
cc (string; Default: )Send a copy to listed recipients. Multiple addresses allowed, use "," to separate entries
file (File[,File]; Default: )List of the file names that will be attached to the mail separated by a comma.
from (string; Default: )Name or email address which will appear as the sender. If a not specified value from the server's configuration is used.
password (string; Default: )Password used to authenticate to an SMTP server. If a not specified value from the server's configuration is used.
port (integer[0..65535]; Default: )Port of SMTP server. If not specified, a value from the server's configuration is used.
server (IP/IPv6 address; Default: )Ip or IPv6 address of SMTP server. If not specified, a value from the server's configuration is used.
tls (yes|no|starttls; Default: no)Whether to use TLS encryption:
  • yes   - sends STARTTLS and continue without TLS if a server responds that drops the session if TLS is not available ;on the server
  • no - do not send STARTTLS;
  • starttls - sends STARTTLS and drops the session if continue without TLS if a server responds that TLS is not available on the server.
subject (string; Default: )The subject of the message.
to (string; Default: )Destination email address. Single address allowed.
user (string; Default: )The username used to authenticate to an SMTP server. If not specified, a value from the server's configuration is used.

...

Info

After the Google mail added a new security policy that does not allow 3d-party devices to authenticate using your standard Gmail passworda workaround solution is you need to generate a 16-digit passcode ("App" password) and use it instead of your Gmail password. To configure this, navigate to the "Security>Singing Security>Signing in to Google" section settings and:

  • Enable 2-Step Verification;
  • generate Generate an App password.

Use the newly generated App password in the "set password=mypassword" setting shown below.

...

Code Block
languageros
/tool e-mail 
set address=173smtp.194.77.108 gmail.com
set port=465
set porttls=587yes 
set from=myuser@gmail.com 
set user=myuser 
set password=mypassword

2. send e-mail using send command with TLS attribute set to yes:

Code Block
languageros
/tool e-mail send to=myuser@anotherdomain.com subject="email test" body="email test" tls=starttls