Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

If a custom routing table is required, it should be defined in this menu prior to use using it anywhere in the configuration.

By default, RouterOS defines the 'main' routing table which adds routes in the FIB.

Code Block
languagetext
themeFadeToGrey
[admin@rack1_b33_CCR1036] /routing/table> print 
Flags: D - dynamic; X - disabled, I - invalid; U - used 
0 D name="main" fib 

Configuration Example

Let's consider a basic example where we want to resolve 8.8.8.8 only in the routing table named 'myTable' to the gateway 172.16.1.1:

...

Code Block
languageros
/routing table add name=myTable fib
/routing rule add dst-address=8.8.8.8 action=lookup-only-in-table table=myTable
/ip route add dst-address=8.8.8.8 gateway=172.16.1.1@main routing-table=myTable

Configuration Options

PropertyDescription
comment (string)
disabled (yes | no)ID reference is not used.
fib
()
Flag indicating whether the routing table should add routes in the FIB.
name (string)Name of the routing table

Read-only Properties

PropertyDescription
dynamic (yes | no)
invalid (yes | no)
used (yes | no)