Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Note: Before trying the wifiwave2 package, make sure to back up any wireless and CAPsMAN configuration you may want to restore afterwards.

...

...

Table of Contents

Requirements

The wifiwave2 package is compatible with IPQ4019 and AR9884 wireless interfaces and is only available for ARM builds of RouterOS v7. It also requires 10MB of free space and at least 256MB of RAM.

...

Following is a non-exhaustive list of wifiwave2 interface properties.

PropertyDescription

band ( 2ghz-g | 2ghz-n | 2ghz-ax | 5ghz-a | 5ghz-ac | 5ghz-an | 5ghz-ax )

Supported frequency band and wireless standard. Defaults to newest supported standard. Note that band support is limited by radio capabilities.

channel-width ( 20mhz | 20/40mhz | 20/40mhz-Ce | 20/40mhz-eC | 20/40/80mhz | 20/40/80+80mhz  20/40/80/160mhz )

Width of radio channel. Defaults to widest supported .
configuration.chains (list of integer [0..7])Radio chains to use for receiving signals. Defaults to all available chains.
configuration.tx-chains (list of integer [0..7])Radio chains to use for transmitting signals. Defaults to all available chains.
configuration.country (name of a country)Determines, which regulatory domain restrictions are applied to an interface. Defaults to "United States", prohibiting use of frequencies 2467-2472 in the 2.4GHz band.
configuration.hide-ssid (yes | no)
  • yes - AP does not include SSID in the beacon frames, and does not reply to probe requests that have broadcast SSID.
  • no - AP includes SSID in the beacon frames, and replies to probe requests that have broadcast SSID.

Default: no

disabled ( no | yes )Whether interface is disabled or not. Interfaces are disabled by default.
frequency ( list of integer )

Frequencies to use for control channel when operating as AP or frequencies to scan for APs on when operating as a station (client). Defaults to all supported channels in the given frequency band.

Note: unlike the standard wireless package wifiwave2 does not support operating on non-standard radio channels (channels without an official number e.g. 5200/ac/Ceee).

mac-address (MAC)MAC address (BSSID) to use for an interface. Defaults to MAC address of the corresponding radio device.
master ( name of an interface )Master interface for virtual interfaces.
mode ( ap | station )Operating mode for the interface. Defaults to 'ap'.
secondary-frequency ( list of integer | disabled )Frequencies to use for the second part of a split 80+80MHz channel.
security.authentication-types ( list of owe, wpa-eap, wpa-psk, wpa2-eap, wpa2-psk, wpa3-eap, wpa3-psk )Authentication types to enable on the interface. Defaults to an empty list (open AP) if security.passphrase is unset or 'wpa2-psk', if it is.
security.passphrase ( string 0..63 chars )Passphrase to use for PSK authentication types. Defaults to "". WPA-PSK and WPA2-PSK authentication requires a minimum of 8 chars, while WPA3-PSK does not have minimum passphrase length.
security.management-protection ( allowed | disabled | required )Whether to use 802.11w management frame protection (incompatible with management frame protection in standard wireless package). Defaults to 'allowed' when PSK authentication is used.
security.owe-transition-interface (name of interface)Name of an interface whose MAC address and SSID to advertise as the matching AP for when running in OWE transition mode. This is required Required for setting up open APs that offer OWE, but also work with older devices that don't support the standard. See configuration example below.
ssid (string)SSID ESSID (extended service set identifier) is a name that identifies wireless network. Default: None.

...

Basic password-protected AP

Code Block
/interface/wifiwave2

...


set wifi1 disabled=no ssid=MikroTik \

...


security.authentication-types=wpa2-psk,wpa3-psk security.passphrase=8-63_characters

Open AP with OWE

Opportunistic wireless encryption (OWE) allows wireless clients to enjoy encryption and management protection without requiring knowledge of a passphrase to connect. It is an improvement on open AP operating mode.

However, the OWE standard does not permit connections from devices that don't support it to prevent downgrade attacks. So to provide an open AP both for clients that don't support OWE and those that do, the following basic configuration is required.

Code Block
/interface wifiwave2

...


add master=wifi1 name=wifi1_owe ssid=MikroTik_OWE \

...


security.authentication-types=owe security.owe-tranistion-interface=wifi1 \

...


configuration.hide-ssid=yes

...


set wifi1 ssid=MikroTik security.authentication-types="" security.owe-transition-interface=wifi1_owe

...


enable wifi1,wifi1_owe

Resetting configuration

You can reset the configuration of a wifiwave2 interface by removing it (e.g. /interface/wifiwave2/remove wifi1) and rebooting the device.

...

Information about the capabilities of each radio can be gained by running the `/interface/wifiwave2/radio print detail` command. The parameter names are self-explanatory and the `radio-mac` property can be used to determine, which wireless interface the radio corresponds toFollowing is a list of radio parameters

PropertyDescription
bandsList of supported frequency bands, wireless standards and channel widths.
ciphersList of supported traffic encryption ciphers.
phy-id

A unique identifier.

radio-macMAC address of the radio interface. Can be used to match radios to interface configurations.
rx-chainsList of IDs for radio chains available for receiving radio signals.
tx-chainsList of IDs for radio chains available for transmitting radio signals.

Registration table

The registration table contains entries of associated wireless devices (both APs and stations) and provides information about their signal levels, data rates and other parameters when using the additional `/interface/wifiwave2/registration-table/print stats` parameter.

...