Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Simplest way to make sure you have absolutely clean router is to run

Code Block
languageperl
themeEclipse
linenumberstrue
/system reset-configuration no-defaults=yes skip-backup=yes

...

Set bridge and IP address is quite easy:

Code Block
languageperlthemeConfluence
linenumberstrue
/interface bridge add name=local
/interface bridge port add interface=ether2 bridge=local
/ip address add address=192.168.88.1/24 interface=local

...

Dynamic address configuration is the simplest one. You just need to set up DHCP client on public interface. DHCP client will receive information from internet service provider (ISP) and set up IP address, dnsDNS, ntp NTP servers and default route for you.

...

To set this in RouterOS we will manually add IP address, add default route with provided gateway and set up DNS server


Code Block

...

language

...

perl

...

linenumbers

...

true
/ip address add address=1.2.3.100/24 interface=ether1

...


/ip route add gateway=1.2.3.1

...


/ip dns set servers=8.8.8.8

PPPoE connection

PPPoE connection also gives you dynamic IP address and can configure dynamically DNS and default gateway. Typically service provider (ISP) gives you a username and password for connection

Code Block

...

language

...

perl

...

linenumbers

...

true
/interface pppoe-client

...


  add disabled=no interface=ether1 user=me password=123

...

 \
    add-default-route=yes use-peer-dns=yes


Winbox/Webfig actions:

  • Open PPP window, Interfaces tab should be sellectedselected;
  • Click on + button, and choose PPPoE Client from the dropdown list, new dialog will open;
  • Select interface ether1 form dropdown list and click on Ok OK button to apply settings.

Note:

Note

Further in configuration

...

WAN interface is now pppoe-out interface not ether1.

Verify connectivity

After successful configuration you should be able to access internet from the router.

Verify IP connectivity by pinging known ip IP address (google dns DNS server for example)

Code Block
languagepowershell
themeFadeToGrey
[admin@MikroTik] > /ping 8.8.8.8
HOST                                     SIZE TTL TIME  STATUS
8.8.8.8                                    56  47 21ms
8.8.8.8                                    56  47 21ms

...

Verify DNS request

Code Block
languagepowershell
themeFadeToGrey
[admin@MikroTik] > /ping www.google.com
HOST                                     SIZE TTL TIME  STATUS
173.194.32.49                              56  55 13ms
173.194.32.49                              56  55 12ms

...


If everything is set up correctly, ping in both cases should not fail.

...