Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Code Block
languageros
/interface lte set lte1 modem-init="AT%CLCMD=1,1,6300,384,\"24701\",6300,385,\"24701\""

...

Cell

...

Monitor

Cell monitor allows to scan available nearby mobile network cells:

Code Block
languageros
[admin@MikroTik] > /interface lte cell-monitor lte1 
PHY-CELLID BAND         PSC EARFCN                 RSRP          RSRQ          RSSI         SINR
        49 B20              6300                -110dBm       -19.5dB
       272 B20              6300                -116dBm       -19.5dB
       374 B20              6300                -108dBm         -16dB
       384 B1               150                 -105dBm       -13.5dB
       384 B3               1300                -106dBm         -12dB
       384 B7               2850                -107dBm       -11.5dB
       432 B7               2850                -119dBm       -19.5dB

...

Gathered data can be used for more precise location detection or for Cell lock.

...

Note
Not all modems support this feature

Troubleshooting

Enable LTE logging:

Code Block
languageros
[admin@MikroTik] > /system logging add topics=lte

...

Check for errors in log:

Code Block
languageros
[admin@MikroTik] > /log print

11:08:59 lte,async lte1: sent AT+CPIN? 
11:08:59 lte,async lte1: rcvd +CME ERROR: 10 

...

search for CME error description online,

...

To check all supported bands run at-chat command:

Code Block
languageros
[admin@MikroTik] /interface lte at-chat lte1 input="AT^SYSCFGEX=\?"

output: ^SYSCFGEX: ("00","03","02","01","99"),((2000004e80380,"GSM850/GSM900/GSM1800/GSM1900/WCDMA BCI/WCDMA BCII/WCDMA BCV/WCDMA BCVIII"),
(3fffffff,"All Bands")),(0-2),(0-4),((800d7,"LTE BC1/LTE BC2/LTE 
BC3/LTE BC5/LTE BC7/LTE BC8/LTE BC20"),(7fffffffffffffff,"All Bands")) 
OK


Example to lock to LTE band

...

 7:
Code Block
languageros
[admin@MikroTik] /interface lte set lte1 modem-init="AT^SYSCFGEX=\"03\",3FFFFFFF,2,4,40,,"

...

Change last part 40 to desired band specified hexadecimal value where:

Code Block
languageros
4 LTE BC3
40 LTE BC7
80000 LTE BC20
7FFFFFFFFFFFFFFF  All bands
etc

...

All band HEX values and AT commands can be found in Huawei AT Command Interface Specification guide

Check if band is locked:

Code Block
languageros
[admin@MikroTik] /interface lte at-chat lte1 input="AT^SYSCFGEX\?"

output: ^SYSCFGEX: "03",3FFFFFFF,0,2,40
OK

...

For more information check modem manufacturers AT command reference manuals.

...

For mPCIe modems to work in RB9xx series devices it is required to set the USB type to mPCIe, this can be done using the following command:

Code Block
languageros
/system routerboard usb set type=mini-PCIe

...

In case your modem is not being recognized after a soft reboot, then you might need to add a delay before the USB port is being initialized. This can be done using the following command:

...

Code Block
languageros
/system routerboard settings set init-delay=5s

...

Modem firmware upgrade

...

Note
Before attempting LTE modem firmware upgrade - upgrade RouterOS version to latest releases How To Upgrade RouterOS


Starting from RouterOS version 6.44beta20 it is possible to upgrade modems firmware.

...

Check currently used firmware version by running:

Code Block
languageros
[admin@MikroTik] > /interface lte info lte1 once

-----
revision: "MikroTik_CP_2.160.000_v008"
-----

...

Check if new firmware is available:

Code Block
languageros
[admin@MikroTik] > /interface lte firmware-upgrade lte1 
  installed: MikroTik_CP_2.160.000_v008
     latest: MikroTik_CP_2.160.000_v010

...

Upgrade firmware:

Code Block
languageros
[admin@MikroTik] > interface lte firmware-upgrade lte1 upgrade=yes
  status: downloading via LTE connection (>2min)

...

Whole upgrade process may take up to 10 minutes, depending on mobile connection speed.

After successful upgrade issue USB power-reset, reboot device or run AT+reset command, to update modem version readout under info command:

Code Block
languageros
[admin@MikroTik] > /interface lte at-chat lte1 input="AT+reset"

...

if modem has issues connecting to cells after update, or there are any other unrelated issues - wipe old configuration with:

Code Block
languageros
/interface lte at-chat lte1 input="AT+RSTSET"
Avoiding tethering speed throttling

Some operators (TMobile, YOTA etc.) allows unlimited data only for device SIM card is used on, all other data coming from mobile hotspots or tethering is highly limited by volume or by throughput speed. Some sources have found out that this limitation is done by monitoring TTL (Time To Live) values from packets to determinate if limitations need to be applied (TTL is decreased by 1 for each "hop" made). RouterOS allows changing the TTL parameter for packets going from the router to allow hiding sub networks. Keep in mind that this may conflict with fair use policy.

Code Block
languageros
/ip firewall mangle
add action=change-ttl chain=postrouting new-ttl=set:65 out-interface=lte1 passthrough=yes

...

More information: YOTA, TMobile

...

Check current PIN code status:

Code Block
languageros
/interface/lte/at-chat lte1 input="at+cpin\?"

...

If card is locked - unlock it by providing:

Code Block
languageros
/interface lte at-chat lte1 input="AT+CPIN=\"PUK_code\",\"NEW_PIN\""

...

Replace PUK_code and NEW_PIN with matching values.