Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...


Point to Point over Ethernet (PPPoE) is simply a method of encapsulating PPP packets into Ethernet frames. PPPoE is an extension of the standard Point to Point Protocol (PPP) and it the successor of PPPoA. PPPoE standard is defined in RFC 2516. The PPPoE client and server work over any Layer2 Ethernet level interface on the router, for example, Wireless, Ethernet, EoIP, etc. Generally speaking, PPPoE is used to hand out IP addresses to clients based on authentication by username (and also if required, by workstation) as opposed to workstation only authentication where static IP addresses or DHCP are used. It is advised not to use static IP addresses or DHCP on the same interfaces as PPPoE for obvious security reasons.

Introduction

PPPoE provides the ability to connect a network of hosts over a simple bridging access device to a remote Access Concentrator.  

...

/ip pool 
add name="pppoe-pool" ranges=10.1.1.62-10.1.1.72

/ppp profile 
add name="pppoe-profile" local-address=10.1.1.1 remote-address=pppoe-pool

/ppp secret 
add name=user password=passwd service=pppoe profile=pppoe-profile

/interface pppoe-server server 
add service-name=internet interface=wlan1 default-profile=pppoe-profile disabled=no

PPPoE Client Scan

PPPoE Scanner allows scanning all active PPPoE servers in the layer2 broadcast domain. Command to run scanner is as follows:

Code Block
languageros
/interface pppoe-client scan [interface]

To add and enable PPPoE client on the ether1 interface connecting to the AC that provides 'testSN' service using user name "user" with the password 'passwd':

[admin@RemoteOffice] interface pppoe-client> add interface=ether1 service-name=testSN user=user
    password=passwd disabled=no
    [admin@RemoteOffice] interface pppoe-client> print
    Flags: X - disabled, R - running
    0  R name="pppoe-out1" max-mtu=1480 max-mru=1480 mrru=disabled interface=ether1
          user="user" password="passwd" profile=default service-name="testSN"
          ac-name="" add-default-route=no dial-on-demand=no use-peer-dns=no
          allow=pap,chap,mschap1,mschap2

    [admin@MikroTik] interface pppoe-client> monitor pppoe-out1
            status: "connected"
            uptime: 6s
        idle-time: 6s
          encoding: "MPPE128 stateless"
      service-name: "testSN"
          ac-name: "MikroTik"
            ac-mac: 00:0C:42:04:00:73
              mtu: 1480
              mru: 1480


Note

For Windows, some connection instructions may use the form where the "phone number", such as "MikroTik_AC\mt1", is specified to indicate that "MikroTik_AC" is the access concentrator name and "mt1" is the service name.


Note

Specifying MRRU means enabling MP (Multilink PPP) over a single link. This protocol is used to split big packets into smaller ones. Under Windows, it can be enabled in the Networking tab, Settings button, "Negotiate multi-link for single link connections". MRRU is hardcoded to 1614 on Windows. This setting is useful to overcome PathMTU discovery failures. The MP setting should be enabled on both peers.


PPPoE Server Setup (Access Concentrator)

...