MikroTik SFP/SFP+/SFP28/QSFP+/QSFP28 compatibility

This article shows the compatibility of MikroTik devices with SFP, SFP+, SFP28, QSFP+, and QSFP28 transceivers. It features detailed compatibility tables that provide valuable insights into which transceivers are suitable for use with MikroTik devices. Additionally, some practical configuration examples are provided using the RouterOS CLI to set different data transmission rates. For more detailed descriptions of properties, please refer to the Ethernet user manual.

MikroTik devices and SFP, SFP+, SFP28, QSFP+, and QSFP28 modules do not have any restrictions for other vendor equipment.

While MikroTik cannot ensure full compatibility with modules from all manufacturers, as long as the other vendor modules and devices comply with transceiver multi-source agreement (MSA) they should be compatible with MikroTik.

1G SFP

ModelS-RJ01S-85DLC05DS-31DLC20DS-3553LC20DS-55DLC80DS-4554LC80DSFP CWDMSFP 1m/3m DACS+AO0005 AOCSFP28 1m/3m DAC
CCR1072-1G-8S+++++++++++
CCR1036-12G-4S++++++++++
CCR1036-8G-2S+++++++++++
CCR1016-12S-1S++ 1+ 1+ 1+ 1+ 1+ 1++++
CCR1009-7G-1C++++++++++
CCR1009-8G-1S-1S+++++++++++
CCR1009-7G-1C-1S+++++++++++
CCR2004-1G-2XS-PCIe----------
CCR2004-1G-12S+2XS++++++++++
CCR2004-16G-2S+++++++++++
CCR2116-12G-4S+++++++++++
CCR2216-1G-12XS-2XQ++++++++++
CRS125-24G-1S++++++++++
CRS305-1G-4S+++++++++++
CRS309-1G-8S+++++++++++
CRS312-4C+8XG-+++++++++
CRS318-1Fi-15Fr-2S++++++++++
CRS318-16P-2S+++++++++++
CRS326-24S+2Q+++++++++++
CRS354-48G/P-4S+2Q+++++++++++
CRS518-16XS-2XQ++++++++++
CRS510-8XS-2XQ++++++++++
CSS/CRS326-24G-2S+++++++++++
CRS317-1G-16S+++++++++++
CRS328-4C-20S-4S+++++++++++
CRS328-24P-4S+++++++++++
CRS226-24G-2S+-+ 2+ 2+ 2+ 2+ 2++++
CRS212-1G-10S-1S++ 1+ 1+ 1+ 1+ 1+ 1++++
CRS210-8G-2S+-+ 2+ 2+ 2+ 2+ 2++++
CRS112-8G/P-4S++++++++++
CRS109-8G-1S++++++++++
CRS106-1C-5S/FiberBox++++++++++
RB5009++++++++++
RB4011+++++++-++
RB3011++++++++++
RB2011++++++++++
L009++++++++ 14+ 14+ 14
RB260/CSS106++++++++++
RB922/921++++++++++
RB953GS++++++++++
hAP AC++++++++++
hEX PoE/PowerBox Pro++++++++++
hEX S++++++++++
RBFTC11++ 8+ 8+ 8+ 8+ 8+ 8+ 8+ 8+ 8
LHG XL 52 ac-+++++++++
RBD22/D23

mANTBox 52 15s/NetMetal ac²

-+++++++++
CSS610++++++++++
CRS310-1G-5S-4S+/netFiber 9++++++++++
CRS310-8G+2S+IN++++++++++

10G SFP+/25G SFP28

ModelS+RJ10S+85DLC03DS+31DLC10DS+2332LC10DSFP+ CWDMSFP+ 1m/3m DACS+AO0005 AOCQ+BC0003-S+XQ+BC0003-XS+SFP28 1m/3m DACSFP28 XS+31LC10DSFP28 XS+2733LC15D
CCR1072-1G-8S+++++++++ 5+ 5+++
CCR1036-12G-4S-++++++--+++
CCR1036-8G-2S+++++++++ 5+ 5+++
CCR1016-12S-1S++ 10+++++++ 1,5+ 1,5+++
CCR1009-7G-1C-++++++--+++
CCR1009-8G-1S-1S++ 10+++++++ 5+ 5+++
CCR1009-7G-1C-1S+++++++++ 5+ 5+++
CCR2004-1G-2XS-PCIe++++++++ 5+ 5+++
CCR2004-1G-12S+2XS+ 11+++++++ 5+ 5+++
CCR2004-16G-2S+++++++++ 5+ 5+++
CCR2116-12G-4S+++++++++ 5+ 5+++
CCR2216-1G-12XS-2XQ++++++++++++
CRS125-24G-1S-++++++--+++
CRS305-1G-4S++ 7+++++++ 5+ 5+++
CRS309-1G-8S++ 4+++++++ 5+ 5+++
CRS312-4C+8XG++++++++ 5+ 5+++
CRS318-1Fi-15Fr-2S-++++++--+++
CRS318-16P-2S+++++++++ 5+ 5+++
CRS326-24S+2Q++ 6+++++++++++
CRS354-48G/P-4S+2Q+++++++++++++
CRS518-16XS-2XQ++++++++++++
CRS510-8XS-2XQ++++++++++++
CSS/CRS326-24G-2S+++++++++ 5+ 5++ 9+ 9
CRS317-1G-16S++ 3+++++++ 5+ 5+++
CRS328-4C-20S-4S++ 10+++++++ 5+ 5+++
CRS328-24P-4S+++++++++ 5+ 5++ 9+ 9
CRS226-24G-2S+++++++++ 5+ 5+++
CRS212-1G-10S-1S++ 10+++++++ 5+ 5+++
CRS210-8G-2S+++++++++ 5+ 5+++
CRS112-8G/P-4S-++++++--+++
CRS109-8G-1S-++++++--+++
CRS106-1C-5S/FiberBox-++++++--+++
RB5009++++++++ 5+ 5+++
RB4011+++++-+--+++
RB3011-++++++--+++
RB2011-++++++--+++
L009-+ 14+ 14+ 14+ 14+ 14+ 14+ 14+ 14+ 14+ 14+ 14
RB260/CSS106-++++++--+++
RB922/921-++++++--+++
RB953GS-++++++--+++
hAP AC-++++++--+++
hEX PoE/PowerBox Pro-++++++--+++
hEX S-++++++--+++
RBFTC11-+ 8+ 8+ 8+ 8+ 8+ 8--+ 8+ 8+ 8
LHG XL 52 ac-++++++--+++
RBD22/D23

mANTBox 52 15s/NetMetal ac²

-++++++--+++
CSS610++++++++ 5+ 5+++
CRS310-1G-5S-4S+/netFiber 9+ 10+++++++ 5+ 5+++
CRS310-8G+2S+IN++++++++ 5+ 5+++

40G QSFP+

ModelQSFP+ Q+DA0001Q+85MP01DQ+BC0003-S+
CRS326-24S+2Q++++
CRS354-48G/P-4S+2Q++++
CRS504-4XQ-IN+++
CRS504-4XQ-OUT+13++13
CRS518-16XS-2XQ+++
CRS510-8XS-2XQ+++
CCR2216-1G-12XS-2XQ+++

100G QSFP28

ModelXQ+31LC10DXQ+31LC02DXQ+85MP01DXQ+DA0001XQ+DA0003XQ+BC0003-XS+
CRS326-24S+2Q+--++++
CRS354-48G/P-4S+2Q+--++++
CRS504-4XQ-IN++++++
CRS504-4XQ-OUT++++13+13+13
CRS518-16XS-2XQ++++++
CRS510-8XS-2XQ++++++
CCR2216-1G-12XS-2XQ++++++


Legend 
Color codes:Not supportedCheck notes below


Notes:

  1. CCR1016-12S-1S+, CRS212-1G-10S-1S+ the SFP+1 interface does not work on any other link speed than 10G (does not support 1.25G fiber optic transceivers)
  2. CRS226-24G-2S+, CRS210-8G-2S+ - the SFP+1 interface also supports SFP 1.25G fiber optic transceivers, SFP+2 works only with 10G transceivers/links.
  3. CSS/CRS317-1G-16S+ - power controller supports up to 10 simultaneous S+RJ10 modules.
  4. CSS/CRS309-1G-8S+ - We do not recommend using S+RJ10 in passive cooling devices without additional cooling, as they have relatively high power consumption and in turn high operating temperature. 
  5. Q+BC0003-S+, XQ+BC0003-XS+ - SFP+ connector support in the SFP+/SFP28 cages
  6. CSS/CRS326-24S+2Q+ - supports up to 12 simultaneous S+RJ10 modules.
  7. CSS/CRS305-1G-4S+ - supports up to 2 simultaneous S+RJ10 modules.
  8. RBFTC11 - works connected to other device 1G SFP port.
  9. XS+31LC10D, XS+2733LC15D - full support has been added to CSS/CRS326-24G-2S+ and CRS328-24P-4S+ switches manufactured from October 2021.
  10. S+RJ10 - support in the SFP+ cages.
  11. CCR2004-1G-12S+2XS - supports up to 6 simultaneous S+RJ10 modules.
  12. CCR2004-1G-2XS-PCIe - supports only the same speed in both SFP28 ports (2 x 25G or 2 x 10G modes).
  13. CRS504-4XQ-OUT - reduce IP code from IP66 to IP54.
  14. L009 - supports up to 2.5G rate (works with forced speed mode).

S-RJ01

Table that states in what link rates if mounted in specific MikroTik devices S-RJ01 module will be able to work. Use these modules only with auto-negotiation enabled, forced link speeds are not supported. They will negotiate to correct duplex and highest possible rate.

Model100010010
RB5009+++
RB4011+++
RB3011+++
RB922+++
RB921+++
hAP ac+++
hEX PoE+++
hEX S+--
RB953+/+-/+-/+
RB2011+--
RB260/CSS106+--
RBFTC11+--
LHG XL 52 ac---
RBD22/D23

mANTBox 52 15s/NetMetal ac²

---
CRS106+++
CRS112+++
CRS125/CRS109+++
CRS212+++
CRS226/CRS210---
CSS/CRS305-1G-4S++++
CSS/CRS309-1G-8S++++
CRS318-1Fi-15Fr-2S+++
CRS318-16P-2S++++
CSS/CRS326-24G-2S++++
CRS354+++
CSS/CRS328-4C-20S-4S++++
CSS/CRS328-24P-4S++++
CSS/CRS317-1G-16S++++
CRS326-24S+2Q++++
CSS610+++
CRS310-1G-5S-4S+/netFiber 9+++
CRS310-8G+2S+IN+++
CCR1009+/++/++/+
CCR1016-12S-1S++++
CCR1036-12G-4S+++
CCR1036-8G-2S++++
CCR1072-1G-8S++++


Notes:

  • Rate works fine: +
  • Rate does not work: -
  • RB953: SFP1/SFP2
  • CCR1009: SFP+/SFP

10 Gigabit Ethernet

S+RJ10

Use these modules only in 10G SFP+ ports with auto-negotiation enabled, forced link speeds and configurable link speed advertisements are not supported. They will negotiate to correct duplex and highest possible rate. For proper S+RJ10 module installation and recommended use case scenarios, please read S+RJ10 General Guidance.

SpeedCable typeS+RJ10 to Ethernet port
10BASE-TCat5e/6100m
100BASE-TCat5e/6100m
1000BASE-TCat5e/6100m
2.5GBASE-TCat5e/6 UTP100m
2.5GBASE-TCat5e/6 STP100m
5GBASE-TCat5e/6100m
10GBASE-TCat6/730m


Negotiated speed highly depends on quality and length of the cables that are used.

S+RJ10 to S+RJ10 always will negotiate to highest possible rate.

The latest revision of S+RJ10 contains "/r2" by the end of serial number. It comes with following improvements:

  • Jumbo frames up to 10218 Bytes at 2.5G, 5G and 10G speeds;
  • Actual link speed reporting;
  • DDM monitoring (Supply Voltage, Module temperature).
Link SpeedMax MTU
10Gbps10218
5Gbps10218
2.5Gbps10218
1000Mbps1504
100Mbps1504
10Mbps1504

CRS312-4C+8XG

10GE ports maximum supported cable length.

SpeedCable type10 Gigabit Ethernet ports
10BASE-TCat5e/6100m
100BASE-TCat5e/6100m
1000BASE-TCat5e/6100m
2.5GBASE-TCat5e/6100m
5GBASE-TCat5e/6100m
10GBASE-TCat6/730m


Negotiated speed highly depends on quality and length of the cables that are used.


10GE ports doesn't support Half duplex mode with forced link speeds.

SFP interface compatibility with 100M optical transceivers

SFP interface on the listed devices is compatible with fast ethernet fiber links.

Compatible devices (interface):

  • CCR1009-7G-1C (combo1)
  • CCR1009-7G-1C-1S+ (combo1)
  • CRS106-1C-5S (combo1)
  • CRS328-4C-20S-4S+ (combo1 - combo4 and SFP1 - SFP20)
  • LHG XL 52 ac
  • RBD22/D23/mANTBox 52 15s/NetMetal ac²

SFP+ interface compatibility with 1G optical transceivers

For MikroTik devices with SFP+ interface that support both 10G and 1G link rate, following settings must be set on both linked devices for required interfaces. These settings only relate when optical SFP transceivers are used. In order to get them working in 1G link rate, use the following configuration:

# Since RouterOS v7.12
/interface ethernet set sfp-sfpplus1 auto-negotiation=no speed=1G-baseX

# Older RouterOS
/interface ethernet set sfp-sfpplus1 auto-negotiation=no speed=1Gbps full-duplex=yes 
  • auto-negotiation disabled
  • port speed 1G
  • full-duplex

Devices which SFP+ ports support 1G links:

  • CCR2004-1G-12S+2XS - All SFP+ interfaces can be used in 1G mode if required.
  • CCR2004-16G-2S+ - All SFP+ interfaces can be used in 1G mode if required.
  • CCR1072-1G-8S+ - All SFP+ interfaces can be used in 1G mode if required.
  • CCR1036-8G-2S+ - All SFP+ interfaces can be used in 1G mode if required.
  • CCR1009-8G-1S-1S+ - All SFP+ interfaces can be used in 1G mode if required.
  • CCR1009-7G-1C-1S+ - All SFP+ interfaces can be used in 1G mode if required.
  • CSS326-24G-2S+RM - All SFP+ interfaces can be used in 1G mode if required.
  • CRS3xx series switches - All SFP+ interfaces can be used in 1G mode if required.
  • RB5009 series - SFP+1 interface can be used in 1G mode if required.
  • RB4011 series - SFP+1 interface can be used in 1G mode if required.
  • CRS226-24G-2S+ - Only SFP+1 supports 1G link speed, SFP+2 is for 10G links only.
  • CRS210-8G-2S+ - Only SFP+1 supports 1G link speed, SFP+2 is for 10G links only.
  • CSS610 series switches - All SFP+ interfaces can be used in 1G mode if required.

Devices which SFP+ interfaces can be used only for 10G links:

  • CCR1016-12S-1S+
  • CRS212-1G-10S-1S+

SFP+ interface compatibility with 10G/25G optical transceivers

MikroTik devices with SFP+ ports can establish 10G links using 10G/25G optical fiber transceivers, however additional SFP Rate Select setting must be configured to avoid data corruption during transmission. The following settings are required on the SFP+ interface:

# Since RouterOS v7.12
/interface ethernet set sfp-sfpplus1 auto-negotiation=no speed=10G-baseSR-LR sfp-rate-select=low

# Older RouterOS
/interface ethernet set sfp-sfpplus1 auto-negotiation=no speed=10Gbps full-duplex=yes sfp-rate-select=low

This requirement applies to MikroTik 10G/25G modules:

  • XS+31LC10D
  • XS+2733LC15D

SFP+/SFP28 interface compatibility with 2.5G transceivers

The 2.5G link rate support is implemented since RouterOS v7.3. MikroTik devices with SFP+ and SFP28 interfaces that support 2.5G link rate require following settings to be set on both linked device interfaces.

# Since RouterOS v7.12
/interface ethernet set sfp-sfpplus1 auto-negotiation=no speed=2.5G-baseX

# Older RouterOS
/interface ethernet set sfp-sfpplus1 auto-negotiation=no speed=2.5Gbps full-duplex=yes
  • auto-negotiation disabled
  • port speed 2.5G
  • full-duplex

Devices which support 2.5G links in SFP/SFP+/SFP28 ports:

  • CRS3xx series switches - All SFP+ interfaces can be used in 2.5G mode if required.
  • CCR2004-1G-12S+2XS - All SFP+ and SFP28 interfaces can be used in 2.5G mode if required.
  • CCR2116-12G-4S+ - All SFP+ interfaces can be used in 2.5G mode if required.
  • CRS518-16XS-2XQ - All SFP28 interfaces can be used in 2.5G mode if required.
  • CCR2216-1G-12XS-2XQ - All SFP28 interfaces can be used in 2.5G mode if required.
  • RB5009 series - SFP+ interface can be used in 2.5G mode if required.
  • L009 series - SFP interface can be used in 2.5G mode if required.

QSFP+/QSFP28 interface supported link rates

In RouterOS, every QSFP+ and QSFP28 physical interface is divided into four subinterfaces. These subinterfaces correspond to the four transmission lines necessary for the operation of QSFP+ or QSFP28. The first digit after "qsfpplus" or "qsfp28-" indicates the numbering of the QSFP+ or QSFP28 physical interface. The second digit, ranging from 1 to 4, indicates each of the individual lines. Here are some examples of QSFP+ and QSFP28 interface printouts for better understanding:

/interface ethernet print 
Flags: R - RUNNING
Columns: NAME, MTU, MAC-ADDRESS, ARP, SWITCH
 #   NAME            MTU  MAC-ADDRESS        ARP      SWITCH 
 1   qsfpplus1-1    1500  48:8F:5A:B6:09:8C  enabled  switch1
 2   qsfpplus1-2    1500  48:8F:5A:B6:09:8D  enabled  switch1
 3   qsfpplus1-3    1500  48:8F:5A:B6:09:8E  enabled  switch1
 4   qsfpplus1-4    1500  48:8F:5A:B6:09:8F  enabled  switch1

/interface ethernet print 
Flags: R - RUNNING
Columns: NAME, MTU, MAC-ADDRESS, ARP, SWITCH
 #   NAME         MTU  MAC-ADDRESS        ARP      SWITCH 
 1   qsfp28-1-1  1500  DC:2C:6E:9E:11:14  enabled  switch1
 2   qsfp28-1-2  1500  DC:2C:6E:9E:11:15  enabled  switch1
 3   qsfp28-1-3  1500  DC:2C:6E:9E:11:16  enabled  switch1
 4   qsfp28-1-4  1500  DC:2C:6E:9E:11:17  enabled  switch1

The configuration and monitoring of each of these subinterfaces can vary based on factors such as auto-negotiation, advertisespeed configuration and transceiver type (e.g. break-out cable or single fiber). Further paragraphs describes in more detail the QSFP+ and QSFP28 supported rates and correct configuration.

Disabling or enabling any of the four QSFP+/QSFP28 subinterfaces causes the entire port group to undergo reconfiguration, leading to a restart of all four lines.

QSFP+ interfaces of MikroTik CRS3xx series devices support following link speeds.

  • 1x 40G
  • 4x 10G
  • 4x 1G

40G links can be established either with autonegotiation or forced 40G speed.
4x 10G and 4x 1G links can be established only with forced speeds and disabled autonegotiation.
In a single link mode only the first QSFP+ subinterface needs to be configured, although rest of the subinterfaces should remain enabled.

Example of forced 1x 40G speed with disabled autonegotiation. Starting from RouterOS version 7.12, in addition to choosing the right transmission rate, it's important to specify the correct link mode. For example, you might use CR4 for Direct Attach Copper (DAC) or SR4-LR4 for an optical module:

# Since RouterOS v7.12
/interface ethernet set qsfpplus1-1 auto-negotiation=no speed=40G-baseCR4
/interface ethernet set qsfpplus2-1 auto-negotiation=no speed=40G-baseSR4-LR4

# Older RouterOS
/interface ethernet set qsfpplus1-1 auto-negotiation=no speed=40Gbps full-duplex=yes

In four link mode all four QSFP+ subinterfaces support configuration of different speeds.

Example of forced 4x 10G speed with disabled autonegotiation:

# Since RouterOS v7.12
/interface ethernet set qsfpplus1-1 auto-negotiation=no speed=10G-baseCR
/interface ethernet set qsfpplus1-2 auto-negotiation=no speed=10G-baseCR
/interface ethernet set qsfpplus1-3 auto-negotiation=no speed=10G-baseCR
/interface ethernet set qsfpplus1-4 auto-negotiation=no speed=10G-baseCR 

# Older RouterOS
/interface ethernet set qsfpplus1-1 auto-negotiation=no speed=10Gbps full-duplex=yes
/interface ethernet set qsfpplus1-2 auto-negotiation=no speed=10Gbps full-duplex=yes
/interface ethernet set qsfpplus1-3 auto-negotiation=no speed=10Gbps full-duplex=yes
/interface ethernet set qsfpplus1-4 auto-negotiation=no speed=10Gbps full-duplex=yes 

QSFP28 interfaces of MikroTik CRS5xx series and CCR2216 devices support following link speeds.

  • 1x 100G
  • 2x 50G (since RouterOS v7.12)
  • 1x 40G
  • 4x 25G
  • 4x 10G
  • 4x 1G

Not supported: 1x 50G, 2x 40G

100G links can be established either with autonegotiation or forced 100G speed.
2x 50G, 1x 40G, 4x 25G, 4x 10G and 4x 1G links can be established only with forced speeds and disabled autonegotiation.
In a single link mode only the first QSFP28 subinterface needs to be configured, although rest of the subinterfaces should remain enabled.

Example of forced 1x 40G speed with disabled autonegotiation. Starting from RouterOS version 7.12, in addition to choosing the right transmission rate, it's important to specify the correct link mode. For example, you might use CR4 for Direct Attach Copper (DAC) or SR4-LR4 for an optical module:

# Since RouterOS v7.12
/interface ethernet set qsfp28-1-1 auto-negotiation=no speed=40G-baseCR4
/interface ethernet set qsfp28-2-1 auto-negotiation=no speed=40G-baseSR4-LR4

# Older RouterOS
/interface ethernet set qsfp28-1-1 auto-negotiation=no speed=40Gbps full-duplex=yes

In four link mode all four QSFP28 subinterfaces support configuration of different speeds.

Example of forced 4x 25G speed with disabled autonegotiation:

# Since RouterOS v7.12
/interface ethernet set qsfp28-1-1 auto-negotiation=no speed=25G-baseCR
/interface ethernet set qsfp28-1-2 auto-negotiation=no speed=25G-baseCR
/interface ethernet set qsfp28-1-3 auto-negotiation=no speed=25G-baseCR
/interface ethernet set qsfp28-1-4 auto-negotiation=no speed=25G-baseCR

# Older RouterOS
/interface ethernet set qsfp28-1-1 auto-negotiation=no speed=25Gbps full-duplex=yes
/interface ethernet set qsfp28-1-2 auto-negotiation=no speed=25Gbps full-duplex=yes
/interface ethernet set qsfp28-1-3 auto-negotiation=no speed=25Gbps full-duplex=yes
/interface ethernet set qsfp28-1-4 auto-negotiation=no speed=25Gbps full-duplex=yes

QSFP+ interface compatibility with QSFP+ to SFP+ breakout cables

MikroTik devices can establish links between QSFP+ and SFP+ ports using breakout cable when following settings are configured on the QSFP+ interface:

# Since RouterOS v7.12
/interface ethernet set qsfpplus1-1 auto-negotiation=no speed=10G-baseCR
/interface ethernet set qsfpplus1-2 auto-negotiation=no speed=10G-baseCR
/interface ethernet set qsfpplus1-3 auto-negotiation=no speed=10G-baseCR
/interface ethernet set qsfpplus1-4 auto-negotiation=no speed=10G-baseCR

# Older RouterOS
/interface ethernet set qsfpplus1-1 auto-negotiation=no speed=10Gbps full-duplex=yes
/interface ethernet set qsfpplus1-2 auto-negotiation=no speed=10Gbps full-duplex=yes
/interface ethernet set qsfpplus1-3 auto-negotiation=no speed=10Gbps full-duplex=yes
/interface ethernet set qsfpplus1-4 auto-negotiation=no speed=10Gbps full-duplex=yes
  • auto-negotiation disabled
  • port speed 10G
  • full-duplex

On the SFP+ side, auto-negotiation remains enabled.

  • No labels