Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Adding Notes

...

  1. Register on my.zerotier.com and create your network, obtain the Network ID XXXXXXXXX;
  2. Download and Install ZeroTier NPK package in RouterOS;
  3. Enable the default (official) ZeroTier instance:

    Code Block
    languageros
    [admin@mikrotik] > zerotier/enable zt1


  4. Add a new network, specifying the network ID you created in the ZeroTier cloud console:

    Code Block
    languageros
    [admin@mikrotik] zerotier/interface/add network=8286ac0e473d**** instance=zt1


    Note

    If an "Access Control" is configured in the "Private" state, then you have to allow RouterOS authorization under Networks "members" section.


  5. Now you might need to allow connections from the ZeroTier interface to your router, and optionally, to your other LAN interfaces: 

    Code Block
    languageros
    [admin@mikrotik] /ip firewall filter> add action=accept chain=forward in-interface=zerotier1 place-before=0
    [admin@mikrotik] /ip firewall filter> add action=accept chain=input in-interface=zerotier1 place-before=0


  6. Verify ZeroTier configuration:

    Code Block
    languageros
    [admin@MikroTik] > zerotier/interface/print
    Flags: R - RUNNING
    Columns: NAME, MAC-ADDRESS, NETWORK, NETWORK-NAME, STATUS
    #   NAME       MAC-ADDRESS        NETWORK           NETWORK-NAME  STATUS
    0 R zerotier1  2A:DD:A1:4C:5C:C9  8286ac0e473d**** testme_mt     OK 


  7. Install a ZeroTier client on your smartphone or computer, follow the ZeroTier manual on how to connect to the same network from there. 

...