Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

The first example consists only of a single IGMP snooping bridge, a single multicast source device, and a couple of multicast client devices. See a network scheme below.

...

The second example adds some complexity. There are two IGMP snooping switches bridges and we need to isolate the multicast traffic on a different VLAN. See a network scheme below.

Image Added

First, create a bridge on both devices and add needed interfaces as bridge ports. The Bridge1 will be acting as an IGMP querier. Below are configuration commands for the Bridge1:

Code Block
languageros
/interface bridge
add igmp-snooping=yes multicast-querier=yes name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=sfp-sfpplus1

And for the Bridge2:

Code Block
languageros
/interface bridge
add igmp-snooping=yes name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=sfp-sfpplus1

Then configure VLAN-related settings. Make sure to configure management access for your devices. It is essential when configuring a bridge with VLAN filtering. In this example, a VLAN 99 interface with an IP address is added to the bridge. This VLAN will be allowed on the tagged sfp-sfpplus1 port. Below are configuration commands for the Bridge1:

Code Block
languageros
/interface vlan
add interface=bridge1 name=MGMT vlan-id=99
/ip address
add address=192.168.99.1/24 interface=MGMT network=192.168.99.0
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,sfp-sfpplus1 vlan-ids=99

And for the Bridge2:

Code Block
languageros
/interface vlan
add interface=bridge1 name=MGMT vlan-id=99
/ip address
add address=192.168.99.2/24 interface=MGMT network=192.168.99.0
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,sfp-sfpplus1 vlan-ids=99

To change port untagged VLAN, use pvid setting. Below are configuration commands for the Bridge1: 

Code Block
languageros
/interface bridge port
set [find interface=ether2] pvid=10
set [find interface=ether3] pvid=10
set [find interface=ether4] pvid=10
set [find interface=ether5] pvid=20
set [find interface=sfp-sfpplus1] pvid=10

And for the Bridge2:

Code Block
languageros
/interface bridge port
set [find interface=ether3] pvid=10
set [find interface=ether4] pvid=10
set [find interface=ether5] pvid=20
set [find interface=sfp-sfpplus1] pvid=10


Note

Bridge IGMP querier implementation can only send untagged IGMP queries. In case tagged IGMP queries should be sent or IGMP queries should be generated in different VLANs, it is possible to install a multicast package, add a VLAN interface and configure a PIM interface on VLAN. The PIM interface can be used as an IGMP querier.

Add bridge VLAN entries and specify tagged and untagged ports. The VLAN 99 entry was already created when configuring management access, only VLAN 10 and VLAN 20 should be added. Below are configuration commands for the Bridge1:

Code Block
languageros
/interface bridge vlan
add bridge=bridge1 untagged=ether2,ether3,ether4,sfp-sfpplus1 vlan-ids=10
add bridge=bridge1 tagged=sfp-sfpplus1 untagged=ether5 vlan-ids=20

And for the Bridge2:

Code Block
languageros
/interface bridge vlan
add bridge=bridge1 untagged=ether3,ether4,sfp-sfpplus1 vlan-ids=10
add bridge=bridge1 tagged=sfp-sfpplus1 untagged=ether5 vlan-ids=20

Last, enable VLAN filtering. Below is the configuration command for Bridge1 and Bridge2:

Code Block
/interface bridge set [find name=bridge1] vlan-filtering=yes