Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Adding point 9.

...

  1. Register on my.zerotier.com and Create A Network, obtain the Network ID, in this example: 1d71939404912b40;
  2. Download and Install ZeroTier NPK package in RouterOS, you can find under in the "Extra packages", upload package on the device and reboot the unit;
  3. Enable the default (official) ZeroTier instance:

    Code Block
    languageros
    [admin@mikrotik] > zerotier/enable zt1


  4. Add a new network, specifying the network ID you created in the ZeroTier cloud console:

    Code Block
    languageros
    [admin@mikrotik] zerotier/interface/add network=1d71939404912b40 instance=zt1


  5. Verify ZeroTier configuration:

    Code Block
    languageros
    [admin@MikroTik] > zerotier/interface/print
    Flags: R - RUNNING
    Columns: NAME, MAC-ADDRESS, NETWORK, NETWORK-NAME, STATUS
    #   NAME       MAC-ADDRESS        NETWORK           NETWORK-NAME     STATUS
    0 R zerotier1  42:AC:0D:0F:C6:F6  1d71939404912b40  modest_metcalfe  OK   


  6. Now you might need to allow connections from the ZeroTier interface to your router, and optionally, to your other LAN interfaces: 

    Code Block
    languageros
    [admin@mikrotik] /ip firewall filter> add action=accept chain=forward in-interface=zerotier1 place-before=0
    [admin@mikrotik] /ip firewall filter> add action=accept chain=input in-interface=zerotier1 place-before=0


  7. Install a ZeroTier client on your smartphone or computer, follow the ZeroTier manual on how to connect to the same network from there.
  8. If "Access Control" is set to "Private", you must authorize nodes before they become members:

  9. Code Block
    languageros
    [admin@MikroTik] > ip/address/print where interface~"zero"
    Flags: D - DYNAMIC
    Columns: ADDRESS, NETWORK, INTERFACE
    #   ADDRESS             NETWORK        INTERFACE
    3 D 192.168.192.105/24  192.168.192.0  zerotier1
    
    [admin@MikroTik] > ping 192.168.192.252 count=3
    SEQ HOST                                     SIZE TTL TIME       STATUS                                                                                                                                           
    0 192.168.192.252                            56  64 407us     
    1 192.168.192.252                            56  64 452us     
    2 192.168.192.252                            56  64 451us     
    sent=3 received=3 packet-loss=0% min-rtt=407us avg-rtt=436us max-rtt=452us 


Tip

You should specify routes to specific internal subnets in the ZeroTier cloud console, to make sure you can access those networks when connecting from other devices. 

...